Back to overview
Maintenance
System Updates
Apr 30, 2026 at 4:00am UTC
–
Apr 30, 2026 at 5:00am UTC
Affected services
DRE RMS Application
Resolved
Apr 30, 2026 at 5:00am UTC
Maintenance ended
Affected services
Created
Apr 30, 2026 at 4:00am UTC
We usually do not have downtime for routine maintenance, but we are making some changes that will require us to take the DRE RMS platform offline for about 1-hour on this occasion.
Affected services